You can't change environment X

After upgrading to enable CI/CD, we can no longer change any data schema or use 8base deploy

The error message “You can’t change environment ‘development’” appears in the 8base CLI and the website.

Is this expected behavior? Is there any better documentation than this page:

Support responded that once an environment has been branched, it can’t be modified directly or deployed directly.

This kind of information really needs to be included in the CI/CD documentation because we wasted a lot of time and potential opportunities trying to debug the issue.

We’re working on improving the docs. Hold tight!

For anyone else who lands here, I think the answer was to delete all of the environments except Master, and then you can use “8base deploy” as expected.

That worked for me when trying to deploy custom functions after enabling CI/CD.

Is that what worked for you @jasonatpuntclub?


It looks like they gave some better info to someone in this thread: Migrate data from one environment to another

Makes things easier when you know what’s going on :slight_smile:

1 Like