Workspace Not Found

Hey I’m having trouble connecting backend from app builder. I get

  "error": {
    "graphQLErrors": [
        "message": "Workspace not found",
        "code": "EntityNotFoundError",
        "details": {
          "workspaceId": "Workspace not found"
    "networkError": null,
    "message": "Workspace not found"

No matter if I try 8base or GraphQL. The workspace is definitely there.

Hi @matkezi could you share your Backend workspace ID, and an example of the GraphQL request you’re using?


yes sir :))
query GetAll
items {

Hi, @matkezi
I’ve checked this workspace and it works well for me.
Can you please check again, if it will not work, I will continue research your concern


Hey, @matkezi ; sorry for the delay in our response; as @eugene.antonevich said, your Backend workspace works well and is reachable, so we could check your frontend calls in the meantime to ensure everything is ok:

Can you please share the workspace Id of AppBuilder?

It’s this one: …

We also need a screenshot of the browser’s console when the request fails to see the REQUEST URL
being called, and a screenshot of how your BackendWorkspace is configured in AppBuilder:

I experienced the exact same problem when just testing out the AppBuilder. I was not able to locate the information you require, but I can tell you what I did to replicate.

  1. Create a backend workspace xback.
  2. Follow the “notes” backend tutorial for that workspace.
  3. Create a frontend workspace xfront.
  4. Add xback as a resource to xfront.
  5. Try to add a simple GraphQL request on that workspace, such as
    query MyQuery {
    notesList {
    items {
  6. “Workspace not found” error.
    I think it is a general bug in the AppBuilder not related to a certain workspace, but that’s just a feeling.
1 Like

Hey @Remirror ,

Welcome to the community! Would you be able to post a couple of screenshots? A screenshot of the resource in app builder like what @carlos.jimenez is showing on the left there would be super helpful. Also if you could let us know your backend workspace ID. Did you enable CI/CD for that workspace?

Thanks much,


In fact I managed to do so:

Backend Workspace ID: clfmebtji00q808md9ekybmut
No CI/CD enabled.

1 Like

Thanks for the info.

Would you be able to select the failed “POST” request and let me know if there’s any information in the Response/Antwort tab?

I have tried to do so, but it says that there is no response data available for this request.

Hello @Remirror , I see in the screenshot that you shared that you are using this API host in the calls to your BE workspace:
however, the host API of your BE workspace is:
That is the cause why you get the “Workspace not found.”
Could you try adding that resource/workspace as a GraphQL API and try again?

Also, could you please share your FE workspaceId? So we can check the calls from there.


I have exact same problem where my frontend cant find workspace. My workspace is hosted @ and I tried changing Endpoint URL as suggested and it does not work, when trying to save it it fails stating workspace is not found.

I also noticed that workspace is recognised by default and I can add it just by clicking on it but when I click on Open Workspace from frontend page that is opened does not work as it should, in a way that I can’t click data or any other tab for that workspace like I would be able to when I open the workspace from the “8base homepage” / “developer page”. When I use Open Workspace from frontend, the opened workspace has: shown as API Endpoint.

Hello, @nsestan.zg
We have found a bug related to the API calls for workspaces hosted in; our team is working on it; we’ll keep you posted.

cc @Remirror

Hey guys - took me ages to find this thread and figure out this issue. I needed to run everything on UK servers for GDPR purposes. Please could you add this to the documentation so other people don’t run into the same problem.

Edit* I added my 8base backend as a GraphQL API resource, generated an API key and added this to the resource as a header