Subscriptions not working in API Explorer of branch environments

Issue Description: What’s happening?

Im trying to test this subscription in a branch environment in the API explorer:

subscription ($collection: ID!) {
  PhotoCollection (
    filter: {
      mutation_in: [create, delete],
      node: {
        collection: {
          id: {
            equals: $collection
          }
        }
      }
    }
  ) {
    node {
      collection {
        collectionPhotoCollectionRelation {
          count
        }
      }
    }
    mutation
  }
}

And the interface stays in a loading state even when i execute actions that should trigger the subscription. I also use the subscription in the app code connected to that environment and it worked for the create action but not for the delete one.

I tested that same subscription on the Master environment and it worked as expected on every case, so i think it is a thing only on branch environments.

Reproduce the Issue: What steps can someone take to replicate the problem?

  1. Create a new branch environment from Master
  2. Try to set up a subscription in the API Explorer with the create and delete event
  3. Trigger actions in the scope of the subscription and nothing happens
  4. Also set the subscription in frontend code with that same branch and the delete mutation does not return nothing

Expected Behavior: What did you expect to happen?

The subscription should return the affected row

Actual Behavior: What actually happened?

Nothing happens

More details or screenshot

@sebastian.scholl is there any guidance on this? We are hitting it too.

This post was flagged by the community and is temporarily hidden.