Sing up with password Method troubles

Hi, i was trying to create a new user with password but it always gives me the same error

what im i doing wrong, is there any way to fix it?

this error occurs due to the fact that the request is sent from 8base api explorer, and accordingly the request is sent from the current user (with the authorization token of the current user)

try to call this mutation from postman ( or altair (

i tried to call this mutation on insomnia , it is the same thing

do you pass authorization header? if so try without

These are all the parameters that i pass

look please at this tab

Do i have to change something here?

hm… what about this tab?

The token, it is an administrator token

try to remove the token

Without the token i cant make mutations or querys

why? what kind of error?

The token gives me the permissions to make mutations and querys from the outside

do you want to call this mutation(userSingUpWithPassword) in a custom resolver, right?
and this resolver will be called for an authorized user?

or will it be used in some other way?

yes, that’s how it has to work
In this case im trying to make this mutation on insomnia with a token that 8base provides me
but i cant create a user because of that error

you can try override headers at custom resolver

const someResolver = (event, ctx) => {
  // some code before ...
  const res = await ctx.api.gqlRequest(
    data, // vars for userSingUpWithPassword mutations
      checkPermissions: false,
      headers: { authorization: null },

  // some code after ...

at the moment there is such a limitation that this mutation (userSingUpWithPassword) must be called without an authorization token

on insomnia it works fine with No Authentication

Did you configure something??, this is the message that it shows me

do you provide authProfileId which exists in this workspace?

yes, you can see it in the pics