Problem on table after creating table with an already existing name

Issue Description: What’s happening?

Because of a earlier problem that i had (Cannot use subscriptions when table names colide), i changed a table’s name from “CompanySubscription” to “CompanySubscriptions”, after doing that i figured out that this change could break backwards compatibility so i thought it was better to create another table with that name.

I tried to do it but obviously the name wask already taken by the table i have just updated. When i saw the error “The table name CompanySubscriptions is already in use” i get out of the view without doing anything else and tried to change the table “CompanySubscriptions” to “CompanySubscription” but the table seems to be broken. It is now throwing me errors.

Reproduce the Issue: What steps can someone take to replicate the problem?

  1. Create a table with a specified name
  2. Create another table with that same name
  3. When an error appears because of the name is already in use, leave that view to the previously created table

I think those are the steps that created this bug for me, i don’t want to replicate this because it could break another table in the database.

Expected Behavior: What did you expect to happen?

Change the name of the table accordingly

Actual Behavior: What actually happened?

The table breaked

More details or screenshot

When the table is fetched:

When i try to change the name on the database:

1 Like

@gerardoagl96 thanks for this report. We will fix that soon!