Migration error like this cannot read properties of undefined (reading 'toString')

I have multiple branch in the 8base and I managed all the branches from my end So I have one issue when I migrate children branch to the master branch with command like

  1. First I set environment with this command to my children branch
    8base environment set

  2. After that I generate migration and it’s created normally with this command
    8base migration generate

  3. And then I checked status for the migration files with
    8base migration status

In the point no. 3 I faced this below error
Cannot read properties of undefined (reading ‘toString’)


I checked debug more with “-d” but not log display on the terminal so can you please let me know what is the solution for this error of the migration and also can you please share with me the step to handle with multiple branch in the 8base for better handling which means I have worked with two branch with same time and after migration one branch How can handle both branch have latest migration

Can you explain more about the multiple branch handle migration as well that would be helpful

Thank you!!!

1 Like

Hi, I am also having the same error message in my terminal, only this time when I try to run 8base deploy -d to an environment branch.

I am using node v18.19.0.

Thank you.

I recommend not to use the new version of 8base CLI yet, it is unstable
0.0.112 is the most stable version at the moment