Impossible to filter query when Allow Multiple is activated on attribute

Hi everyone,

When activating the option Allow multiple on a Text field attribute, the attribute is no longer available in <TableName>Filter type in the API Explorer, and running the query returns an error.

When removing the Allow multiple option, the attribute re-appears in the Filter options.

How could we filter a table on a Text field attribute when the option Allow multiple is activated?

Thanks in advance,


Hello Andréas!

I’m not sure that this is correct behavior. I’ve asked our team. I will let you know soon.

Lada | Kokotova | Technical Support Engineer

Hello Andréas!

Sorry, it’s a bug. We’ll fix it in the near future.
Thank you for your questions. They help to make our product better!

Lada | Kokotova | Technical Support Engineer

1 Like

Awesome! Thanks. Let me know when the issue is fixed.

Best wishes for 2022,


Sure! Thanks!

Lada Kokotova | Technical Support Engineer

Hello Andréas!
Update here: this is excepted behavior - you can’t filter multiple fields due to limitations of our back-end architecture (SQL specifically). I don’t think this feature will be added in the near future, but I’ll raise up the feature request for discussion with the team to know if it’s possible to implement at all.

Hello @Fomich!

Thanks for your reply. Ideally, the only thing we would want to know is whether the multiple fields is empty or not. Do you think this could be enabled?

Otherwise, do you have any workaround to suggest?