Following tutorial, can't create a row

Hi there, first post. I’ve been reading about 8base and really does seem the exact right solution I need to build an app from the ground up (as a UI/UX designer), however, I’m just on Course 2 and when I Create New Row, the button just spins and nothing happens. I’ve tried different browsers, on mac, and tried again today, to no avail.
[8base Academy - Defining Data Tables and Relationships in the Data Builder - Course 2 - YouTube]

I don’t really want to move past it as I think it’s an important part to help me determine whether 8base is correct, thank you

Hello John!

Could you share with us a screenshot or a recording where we can see your error?


1 Like

Just here

Thanks for your reply, and sorry I didn’t remove my background music.

Also, I’ve whitelisted from adguard, used chromium and safari, it’s all still a no-go

Oh, I see. Can you share with me your workspace Id? We will check what’s happening there.

yes, how would I do that?

ok, found it, is it ok to paste it here?

I just messaged you on LI. Although obvo paste the solution on here, as I don’t think it’s unique to my setup, thanks Juan

Hey @john

Here is the solution for your problem:

The 8base team already checked your workspace, and we could see that there is a problem with the Author field in the Posts table. This field is of mandatory type, so in order for what you want, you must delete the Author relationship and create it again but without the mandatory option.

For more explanation please read below:

8base server has relation fields. Relation fields could be implemented by 2 ways:
Pivot tables: The relation data is stored in a third table.
Foreign key: Mysql solution with foreign key restriction.

We released supporting foreign key relation field implementation. After this release, all fields that you create would be implemented with the classic relation mechanism.

The 8base server has its language to connect/disconnect relations. To connect records the client’s web use this syntax, but after the release, this syntax couldn’t work with foreign key implementation in case of mandatory fields because the server splits create operation on two: insert scalar data + connect, but since scalar data from this moment requires a foreign key field, MySQL throws the error. It could work if you create One - Many relation without a mandatory option

If you have any doubts, you can reply me :slight_smile:

1 Like

Ok, thanks guys, will check it out. But it’d just be cool if the app itself explained what was wrong, at least if it gave me an error code that I could look up (a minimal solution to human error though).

Please don’t let this continual spin be the behaviour, it’s like asking your gf/bf wtf is wrong now. Speak now, or forever hold your spin.

Thanks for your feedback @john. This bug has already been reported and we are working to provide a better user experience and documentation of the case.

1 Like

arghh, so I have to avoid the Syntax Error again? Bad memories of the VIC 20 days when anyone was blamed for walking while the cassette was still loading Blitz! (btw, I never quite completed Blitz!, the fkn spacebar). Syntax Error w/o reason, welcome to my life, s’ok there’s a hotel nearby

many thanks Juan. I appreciate that you take time to explain things to me, rather than that SO or Apple/discussion level 10 type knobheads,

Thanks guys, designer-developer need to get to the same understanding in order to create things better. We both look at things differently, but not separately.

1 Like