Field can't be set to No Duplicate Values even after duplicate rows are deleted

Issue Description: What’s happening?

Field cannot be switched to “No Duplicate Values” even if all duplicate values are removed.

Reproduce the Issue: What steps can someone take to replicate the problem?

  1. Create a table in the data builder
  2. Add a custom text field named “Text”
  3. Create two new rows that both have “a” in the “Text” field.
  4. Go to Schema and try to change the field to No Duplicate Values.
  5. As expected, this produces an error.
  6. Delete one of the rows.
  7. Try to change field to No Duplicate Values.
  8. Same error occurs.

Expected Behavior: What did you expect to happen?

The change to No Duplicate Values would be successful once one of the duplicate rows was deleted.

Actual Behavior: What actually happened?

The same error was produced.

More details or screenshot


Hello, Jake!

We’re aware of the problem actually and it will be fixed in one of the future releases.
The solution is to use <tableName>Destroy or <tableName>DestroyByFilter mutation for these data records to delete it completely before making field unique.

1 Like