Error While Adding Field to Table

Hi There,

Issue Description: What’s happening?

I’m adding a new field to a table. The “processing” animation spins for a moment and then does nothing. The field is not being added, so when I click away I get “save changes” pop-up.

I was able to add a field to a different table. Is there a limit on the number of fields within a table? For added context this is using the 8base Table Builder, ie the web based GUI. Querying the aforementioned table works just fine.

Reproduce the Issue: What steps can someone take to replicate the problem?

  1. Start adding a new field
  2. Click “create field”

Expected Behavior: What did you expect to happen?

Field should be created

Actual Behavior: What actually happened?

Field is not being created

Any idea what might be going on?

Looking in the browser console I see the following error.

Addendum.

The same thing happens with same error when I try to update a field. In this case updating a number field to be a Big Number.

Updated. Tried to add a new field today. No functional change but got a different error.

@sebastian.scholl, any idea what might be going on? This is a breaking bug for our team.

@ilya.8base can you guys check this out?

Thanks Sebastian and @ilya.8base for looking into it! Definitely no rush over the holidays!

1 Like

@ilya.8base and @sebastian.scholl, have you had the chance to take a look at this by chance? Still unable to make changes to the table in question.

Just attempted twice and got these two errors. Any help would be greatly appreciated!

Hmmmm… This must be a workspace specific issue as I’ve been adding tables/fields to my own projects the past few days.

Please go to 8base.com and use the Chat window to open a support ticket. Say you are a Developer with a Technical Question and Open a Support Ticket. Please include the workspace ID and table name in your ticket!

1 Like

Thanks for the direction @sebastian.scholl. I started the ticket 2 days ago (when you recommended to do so) and have not heard anything or gotten email confirmation the ticket was received.

Any idea of quickly the team normally gets to support tickets (or at least to confirm it was received)? I understand that everyone is probably ramping back in after the holidays.

@jcollingj is this resolved for you?

@sebastian.scholl

No. Not resolved and I have also not received any information from the support team. I am continuing to not be able to make any changes to one of my tables.

What can I do to get support in resolving this? Happy to jump on a call with support at any time.

Hey @sebastian.scholl, sorry to be a pest about this. But the table in question is central to our application and I’m worried about not being able to update it in the future. I can update other tables in my workspace, but not this one.

Can you connect me with the support team? I have not received anything back from the help desk ticket created two weeks ago.

Additionally, I tried to update the table in question from the API explorer using System.FieldCreate and got a different set of errors. So it seems it’s not just the Data Builder but something deeper perhaps?

The error below:
{
“errors”: [
{
“message”: “Network error: Failed to fetch”,
“stack”: “Error: Network error: Failed to fetch\n at new t (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:1217740)\n at Object.error (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:1235109)\n at A (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940235)\n at y (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940690)\n at e.value (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4941307)\n at https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:1232376\n at Set.forEach ()\n at Object.error (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:1232338)\n at A (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940235)\n at y (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940690)\n at e.value (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4941307)\n at Object.error (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:5251402)\n at A (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940235)\n at y (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940690)\n at e.value (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4941307)\n at Object.error (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:2730556)\n at A (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940235)\n at y (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4940690)\n at e.value (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:4941307)\n at e. (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:3387151)\n at https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:485260\n at Object.next (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:485365)\n at a (https://app.8base.com/static/js/64.9f5285b1.chunk.js:1:484135)”