DateTime Localization

Hi,

First of all, nice product so far :smiley:

We are importing data in a task as
dateTime: ‘2020-02-17T08:00:00.000Z’,

When using the API Explorer we see the data as 2/17/2020, 9:00 AM.

We have tried with Localization Settings to UTC +00:00 and UTC+01:00 with the same result.

Please advice :smiley:

Hey @frippera ! Thanks for the compliments :slight_smile:

I just ran a query in a workspace to check the format of returned dates, it showed the TZ string…

    {
      "createdAt": "2019-12-29T22:47:28.779Z"
    },
    {
      "createdAt": "2019-12-29T22:47:56.127Z"
    },
    {
      "createdAt": "2019-12-29T22:48:18.546Z"
    },
    {  

Can you help me understand where you’re seeing that format being returned?

My Bad, I wrote the “API Explorer” when I ment “DATA” Tab. :neutral_face:

This date is imported as “2020-01-28T14:20:00.000Z”

03

No worries! I was confused.

We don’t have the option to change the default format of dates in the Data Viewer at this time. It’s a nice customization though. I’ll suggest it to the team.

Ok,

When u look in the data tab it’s is for me like looking i the DB table. It’s very strange behaviour if this data is not shown as it is stored.

There are already two places to set Timezone in 8base.

  1. One in your Profile -> Timezone
  2. And the second in Settings -> Localisation -> Default Timezone

How are they different from each other and what do they change?

BR
Anders

1 Like

@sebastian.scholl Any thoughts on this or updates from the Team?