Can't set field to No duplicates due to weird cache issue?

I accidentally ended up with a bunch of duplicate rows in my table.

So I wanted to make one of the fields unique to make sure it couldn’t happen again.

I deleted ALL rows in the entire table (it’s completely empty)

I set the field to a max length of 190 characters and saved it (that worked fine).

Then I tried setting the field too No Duplicate Values and I get this error:

The field 'url' has non uniques values. Please remove duplicate values and repeat the operation. Non unique values are:,,,,

These are the duplicate values from the rows I deleted.

Figuring this was just an issue of trying to do it took fast, I waited 10 minutes and then tried again. But the problem persists.

I’ll try again later I guess. But whatever is causing this is very annoying. Fine if it takes a minute or so, but an hour or however long this will take before I can set a field to not have duplicates is a bit much.

An hour later and I still can’t set the field to No Duplicates with the same error :frowning:

@MarkLyck does empty the table an option?

@sebastian.scholl it’s now been multiple days and I still can’t set the field to no duplicates???

@alacret the table was empty. Now there’s a few records. in it but every row is unique.

seems like a bigger issue than just cache?

@MarkLyck we will take a look into this on Monday.

1 Like

Was this fixed? @ilya.8base

@MarkLyck as you know we are working on hard delete function. This will be solved after we release it. For now you could remove field and create new one. Please let me know if it helps.


Didn’t know you were working on hard delete. That’s great news!

Are you saying if I empty out my table again, remove the field from the schema and then re-create it before any new rows are added, I can make it unique without issues?