8base deploy - not working

I have 2 projects on 8base, and cannot deploy anything using 8base deploy to either of them.

When I try to deploy my changes I get the following error which is not very helpful :frowning:

error: Something went wrong during deploy. Please contact support@8base.com if the error persists.
error: Time: 9,304 ms.

I have tried updating to the latest 8base CLI.

I’ve run 8base whoami to check that I am authenticated.
I’ve run 8base package which finishes successfully
I’ve invoked my changed functions locally and they run just fine.
I’ve run 8base configure to make sure it was on the right project.
I’ve run 8base describe and it lists all the correct functions.

None of that helped me be able to debug this issue without support.

Can anyone please help figure out what’s going on? And as a feature request. It would be really nice wit a more informative error message than “something went wrong”

Hey Mark!

I just installed the latest version of 8base-cli, initialized a new project, ran the deploy command and everything worked.

I think this may be something in your code that is trigging a failed compilation. Is there anyway you can share some of the latest changes so we can look at what might be triggering this?

I agree that we need to improve the error message, regardless!

@MarkLyck there was an issue with displaying compilation errors. It’s fixed now.

1 Like

@evgeny.semushin @sebastian.scholl Thank you so much for fixing this.

Immediately made it clear what the issue was and I can deploy again.

Ended up being a Type issue, a variable could technically have a “never” type it shouldn’t be able to have.

Thanks so much for the quick fix!

1 Like