8base AUTH error

i tried to sing up using 8base auth but it doesn’t work, i don’t know why, it shows me this error:

“Authorization profile connection does not exist.”

how can i fix this?

Check out this solution, it should help you

If it doesn’t help, write me an email - schedule a call with you to help configure auth0

Does this auth profile point to your own auth0?

thanks, i will check it

No, it’s 8base AUTH0

Provide workspace id, please

Here it is: ckv06nj9d018a09mo2fy22uj7

Hi! We’ve found the problem.

  1. Each auth profile has a type.
    8BASE_COGNITO - profile that points to 8base’s cognito default authentication (we’re using it now).
    8BASE - profile that points to legacy 8base’s auth0 default authentication (we don’t use it anymore).
  2. At some moment in the past the server started to use 8base cognito authentication as default auth system beside auth0, so the workspaces that were created after this moment would use cognito auth system.
  3. You had auth profiles with 8BASE_COGNITO type before and seems like everything was good.
  4. Looks like you’ve deleted your previous auth profile and managed to create a new auth profile without specifying the type of it - so it was created with legacy type ‘8BASE’ due to a server-side bug.
    Actually, it’s a pretty damn tricky case, so thanks a lot for helping us find it.

How to fix it right now:

  1. delete all existing auth profiles
  2. create a new one specifying the “type” - “8BASE_COGNITO” via “API Explorer”
mutation createNewAuthProfile {
    name: "newAuthPlan",
    type: "8BASE_COGNITO",
    selfSignUpEnabled: false,
    roles: {
      connect: [
          id: "ckv06nv6d005c09ib9twqfzs6"
      selfSignUpEmailDomains: []})

Thanks, it gave me a solution to that problem “Authorization profile connection does not exist”,
But now it shows me “Self signup is disabled for this workspace” and im still using 8base Auth, and i can’t use “self sing up” with the free trial, do i have to pay for using it or is it a bug too?

We’ve enabled this feature for the free-tier plan. Check it, please.

1 Like

Thanks, it worked, i saw that the methods with social media login are not included in the free trial any more, do i have to pay for the developer plan?

Hello @jetixsolorzano!
Sorry for the delay - you were able to see social media sign-in methods for the default legacy 8base auth plan because of the bug. It’s deprecated for the current default Cognito 8base auth plan. But they are still available for custom auth0 profiles.